[ic] installation issue

Rick Bragg lists at gmnet.net
Wed Dec 30 16:51:33 UTC 2009

On Wed, 2009-12-30 at 18:00 +0200, Gert van der Spoel wrote:
> Hi,
> Trying to install interchange and running into the:
> We're sorry, the Interchange server is unavailable... 
> We are out of service or may be experiencing high system demand. Please try
> again soon.
> Tried all the, as far as I know, checks, but to no avail.
> - This is perl, v5.10.0 built for i486-linux-gnu-thread-multi
> - osname=linux, osvers=2.6.26-2-amd64, archname=i486-linux-gnu-thread-multi
> - interchange 5.7.4 nightly build ... 
> - as far as I know no selinux running 
> - tried running with SocketPerms=0666
> - on restart socket file is recreated
> also recompiled vlink just in case (because of the 64bit and having a
> catalog coming from a 32bit environment)
> btw make test says:
> # When the above test fails, it may be due to your ISP or some other
> # mechanism blocking port 8786.
> should that be 8786 or 7786?
> as here it is 7786 http://icdevgroup.org/docs/glossary/link-program.html
> in test.pl it has: $ENV{MINIVEND_PORT} = 8786 unless defined
> CU,
> Gert

As far as I know, the port number is only used with tlink.  I use a
number of different ports on my test server (tlink) in order to have
many IC servers up at once. 

Maybe try setting the socket perm to 777 as a test?  Obviously check out
ps aux | grep interch and netstat -a |grep interch to see if it is up...


More information about the interchange-users mailing list