[ic] Error while interpolating page etc/report: UTF-8 Issue

Stefan Hornburg (Racke) racke at linuxia.de
Mon Jun 1 14:40:43 UTC 2009

IC wrote:
>>> Hi folks,
>>> I am running IC 5.6.0 with UTF-8, I get the following error message
>>> which I
>>> think is due to having the GBP £ symbol in the etc/report template, the
>>> error I get is:-
>>> Error during creation of order routing main:
>>> Error while interpolating page etc/report:
>>> Can't find Unicode property definition "Word" at
>>> /usr/local/interchange/lib/Vend/Interpolate.pm line 3513.
>>> Does anyone know how I can display the £ symbol in the report without
>>> getting this error, as it is plain text I cannot use &pound or the
>>> other
>>> variants.
>> And did you try without the £ symbol and then the error disappeared, just
>> to
>> be sure it is related?
>> Is the £ symbol properly converted to UTF-8?
>> CU,
>> Gert
> Hi Gert,
> On the main server I removed the £ symbols and didn't see the error again,
> however on a backup server running the same version of IC with UTF-8 the
> same report template with the £ symbol didn't generate the error. I did
> however get an error on this server from etc/mail_receipt which again seems
> to be £ symbol related.
> It would be nice to have the symbols but I could switch to GBP or just the
> digits.

Do you have more than one catalog running on these server(s)?
If yes, do they have UTF-8 enabled?


LinuXia Systems => http://www.linuxia.de/
Expert Interchange Consulting and System Administration
ICDEVGROUP => http://www.icdevgroup.org/
Interchange Development Team

More information about the interchange-users mailing list