[ic] Upgrade procedure

Grant emailgrant at gmail.com
Tue Jun 16 17:01:18 UTC 2009

>> I don't know why dbconf/default_db/variable.dbm is conflicting with
>> dbconf/mysql/variable.dbm since dbconf/default_db/access.dbm and
>> dbconf/default_db/mv_metadata.dbm aren't conflicting with their
>> identical copies in dbconf/mysql.
> As someone else mentioned, normally dbconf/default_db/* is not used at all
> if you're using an SQL database.
> Feel free to delete the entire dbconf/default_db directory, as you should
> have no need of it.
>>> Grant, I think something must be old there: Either the Business::UPS,
>>> or the ups-query tag, or something, because I don't get any warning on
>>> startup, and I don't see the $result variable mentioned in your error
>>> message in either Business::UPS or ups_query.tag.
>>> Are you sure you don't have an old ups-query tag floating around in a
>>> different directory, catalog.cfg, or one of its includes?
>>> Is there a $result variable in your Business::UPS source at line 97 as
>>> the error would indicate?
>> Yeah I sure do have $result at line 97.  I guess I've got an old
>> version?  Are you on the latest?  I just installed Interchange::Bundle
>> via IC's 'make install', and shouldn't Business::UPS have been updated?
> Aha. Look carefully at Bundle::Interchange. It doesn't actually include
> Business::UPS! It mentions it in the description, but isn't specified as
> one of the dependencies. So you probably didn't update it when you thought
> you did. Try updating it by hand.
> If that still doesn't work, search your Perl include paths to see if
> there's an old version earlier in the path than the new one you install.
> BTW, Bundle::InterchangeKitchenSink *does* include Business::UPS.
> Jon

Got it, thanks Jon.  I just tried to install
Bundle-InterchangeKitchenSink via Gentoo's g-cpan but this list of
dependencies looks ridiculous:

[ebuild  N    ] perl-gcpan/OLE-Storage-Lite-0.18
[ebuild  N    ] perl-gcpan/IO-Stty-0.02
[ebuild  N    ] perl-gcpan/Set-Crontab-1.02
[ebuild  N    ] x11-misc/util-macros-1.2.1
[ebuild  N    ] dev-perl/OLE-StorageLite-0.14
[ebuild  N    ] perl-core/Text-Balanced-2.0.0
[ebuild  N    ] perl-gcpan/Image-Size-3.2
[ebuild  N    ] dev-perl/IO-Tty-1.07
[ebuild  N    ] dev-perl/TermReadKey-2.30
[ebuild  N    ] dev-perl/Term-ReadLine-Perl-1.03.02
[ebuild  N    ] dev-lang/tcl-8.4.18  USE="-debug -threads"
[ebuild  N    ] dev-perl/Unicode-Map-0.112
[ebuild  N    ] x11-proto/xproto-7.0.14
[ebuild  N    ] x11-libs/xtrans-1.2.3  USE="-debug"
[ebuild  N    ] x11-proto/kbproto-1.0.3
[ebuild  N    ] x11-proto/inputproto-1.5.0
[ebuild  N    ] dev-perl/Spreadsheet-ParseExcel-0.32  USE="unicode -cjk -test"
[ebuild  N    ] x11-proto/xf86bigfontproto-1.1.2
[ebuild  N    ] x11-proto/bigreqsproto-1.0.2
[ebuild  N    ] x11-proto/xcmiscproto-1.1.2
[ebuild  N    ] virtual/perl-Text-Balanced-2.0.0
[ebuild  N    ] dev-perl/Parse-RecDescent-1.94
[ebuild  N    ] x11-libs/libICE-1.0.4  USE="-debug -ipv6"
[ebuild  N    ] x11-proto/xextproto-7.0.4
[ebuild  N    ] x11-libs/libXau-1.0.4  USE="-debug"
[ebuild  N    ] x11-libs/libXdmcp-1.0.2  USE="-debug"
[ebuild  N    ] x11-libs/libX11-1.1.5  USE="-debug -ipv6 -xcb"
[ebuild  N    ] dev-perl/Spreadsheet-WriteExcel-2.20
[ebuild  N    ] x11-libs/libSM-1.1.0  USE="-debug -ipv6"
[ebuild  N    ] x11-libs/libXt-1.0.5  USE="-debug"
[ebuild  N    ] dev-lang/tk-8.4.18-r1  USE="-debug -threads"
[ebuild  N    ] perl-gcpan/Bundle-InterchangeKitchenSink-1.06

I'll see if I can figure this out.

- Grant

More information about the interchange-users mailing list