[ic] Call for testers

David Christensen david at endpoint.com
Thu Mar 12 04:15:28 UTC 2009

>> Greetings interchange enthusiasts!
>> As we all know, UTF-8 support in interchange has been a bit of a  
>> mixed
>> bag.  We aim to rectify this issue by identifying and fixing these
>> issues, but we need people who are willing to test the latest and
>> greatest versions of the fixes.  I have set up a specific github
>> repository to track the changes (http://github.com/machack666/interchange-utf8/tree/utf8
>> ).  ***Please note that this code is considered *experimental* and
>> should *not* be run on a production system at this point.***
>> Nevertheless, if you have some spare hardware or spare cycles, or  
>> have
>> a copy of your site that you can easily set up in a testing
>> environment, we need your help.
> I tried hard to found a case where it barfs :-).
> 1. Autoload calls local $Tag->form();
> 2. $Tag->form() calls $Tag->run_profile();
> 3. Profile has embedded Perl code with
>    Log("CGI: " . uneval($CGI));
> 4. Safe: 'require' trapped by operation mask at
> /usr/lib/interchange/Vend/Util.pm line 656.


I have pushed a patch which creates Vend::Safe, a trivial wrapper  
around Safe which initializes all compartments at creation time.  I  
believe this will fix this issue.  Can you pull and report back?  This  
is the first time I've added a module to core, so I had to `make  
clean` and then `perl Makefile.PL` before it would install in my local  
interchange instance.  Is this usual?


David Christensen
End Point Corporation
david at endpoint.com

More information about the interchange-users mailing list