[ic] Upgrade to Interchange-5.7.4 performance issues

Bill Carr bill at bottlenose-wine.com
Thu Feb 11 12:40:32 UTC 2010

On Feb 11, 2010, at 2:10 AM, Jon Jensen wrote:

> On Wed, 10 Feb 2010, Bill Carr wrote:
>> However, 5.7.4 runs much slower. Pages that get served on in under 5 seconds are taking 10, 20, 30 seconds or longer. The load average on each host running 5.7.4 goes from under 2 to near 10. I'm running the rpc mode from interchange.cfg.dist. Configuration is the same for 5.4.0 and 5.7.4 (besides small changes with actionmap api). I know 5.7.4 is not a production release. I'm just trying to bring my setup up to date. Been running a hacked up 5.4.0 for a while.
>> Any ideas on why this would be or how I should debug it?
> I haven't seen any slowdowns like that. My best guess would be that it's related to the new character set encoding stuff. What UTF8-related directives or variables do you have?
Variable 	MV_CHARSET 			UTF-8
DatabaseDefault MYSQL_ENABLE_UTF8 1
DatabaseDefault GDBM_ENABLE_UTF8 1


Also, on 5.7.4 I was having some character encoding issues. UTF-8 encoded pages with characters containing diacritics were not displaying properly in 5.7.4 but the same page served up by 5.4.0 was fine. Characters coming out of the database with diacritics were displaying fine in 5.7.4.

> Did you change anything about Perl at the same time?
No. I have it setup so I can just switch the IC version and leave everything else the same. Same IC config. Same perl.

Bill Carr 
Bottlenose - Wine & Spirits eBusiness Specialists 
(413) 584-0400 
 Download vCard

More information about the interchange-users mailing list