[ic] Upgrade to Interchange-5.7.4 performance issues

Bill Carr bill at bottlenose-wine.com
Thu Feb 11 15:50:25 UTC 2010

On Feb 11, 2010, at 10:34 AM, David Christensen wrote:

> On Feb 11, 2010, at 1:10 AM, Jon Jensen wrote:
>> On Wed, 10 Feb 2010, Bill Carr wrote:
>>> However, 5.7.4 runs much slower. Pages that get served on in under 5 seconds are taking 10, 20, 30 seconds or longer. The load average on each host running 5.7.4 goes from under 2 to near 10. I'm running the rpc mode from interchange.cfg.dist. Configuration is the same for 5.4.0 and 5.7.4 (besides small changes with actionmap api). I know 5.7.4 is not a production release. I'm just trying to bring my setup up to date. Been running a hacked up 5.4.0 for a while.
>>> Any ideas on why this would be or how I should debug it?
>> I haven't seen any slowdowns like that. My best guess would be that it's related to the new character set encoding stuff. What UTF8-related directives or variables do you have?
> There have been reports of slower regexes in some cases when using UTF8 strings; in particular unanchored regexes like /.*foo/ will sometime take a much longer time to process.  (The IC parser is made almost exclusively of regexes, many of which fall into this category.)  I believe this is a perl bug, but I'm not sure if this has been fixed in later perl versions or not.  What version of Perl/Encode are you using?
perl v5.10.0 built for x86_64-linux

Encode 2.39

> As a workaround, you can disable the MV_UTF8 as mentioned upthread, or try a newer Perl version to see if it has been solved there.
I had this disabled initially and it still went slow.

I'll try perl 5.10.1 now.

Bill Carr 
Bottlenose - Wine & Spirits eBusiness Specialists 
(413) 584-0400 
 Download vCard

More information about the interchange-users mailing list