[ic] process.html 404 errors

Gert van der Spoel gert at 3edge.com
Mon Mar 15 07:01:45 UTC 2010

> -----Original Message-----
> From: interchange-users-bounces at icdevgroup.org [mailto:interchange-
> users-bounces at icdevgroup.org] On Behalf Of Grant
> Sent: Monday, March 15, 2010 3:54 AM
> To: interchange-users at icdevgroup.org
> Subject: Re: [ic] process.html 404 errors
> >>>>>> My domain doesn't have any non-alphabetic characters.  It
> actually
> >>>>>> just happened again with the following UA:
> >>>>>>
> >>>>>> Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us)
> >>>>>> AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4
> >>>>>> Safari/531.21.10
> >>>>>>
> >>>>>> Can anyone test an IC site on a Mac with Safari and cookies
> disabled?
> >>>>>> Or even a Windows machine?
> >>>>> Tried it with Safari4 / Windows.  It happens when I click on a
> >>>>> one-click
> >>>>> search URL, it does not include the id= component in the url for
> those
> >>>>> in the standard demo.  The URL ends with open=.
> >>>>>
> >>>>> It appears this may be the case in other browsers as well.  It
> looks to
> >>>>> do this with Opera / Linux at the very least.  More testing on
> the way.
> >>>>
> >>>> Yep, even in FF / Linux, the "Hand Tools" link on the left does
> not have
> >>>> a session ID.
> >>>
> >>> This would appear to be due to the timed build of the product tree.
>  Any
> >>> suggestions on how to best work around that?  Perhaps only
> timed_build
> >>> if a cookie is present?
> I don't use a timed build so the issue I'm seeing must be different,
> but I think I've found an IC bug.  I've just seen the same problem
> again from another Mac/Safari user:
> Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us)
> AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
> The user had a [read-cookie MV_SESSION_ID] value containing a
> different IP address from a previous visit a few days earlier.  That
> previous visit worked perfectly, I can see that the session ID was
> consistent throughout the IP's activity.  During the user's most
> recent visit on a new IP, the session ID changed with every page
> access.
> Since the MV_SESSION_ID cookie should expire at the end of every
> browser session, I'm thinking the user must have visited the site via
> one connection, and then switched connections without closing the
> browser.  The session cookie containing the wrong IP address must be
> causing IC's session persistence to fail.
> Can anyone here access the internet via 2 different IPs to test this?
> Even better if you can use Safari, even better if you can use a Mac.

No Mac/Safari, but tried some with 2 different IPs while having old browser
open etc.
I tested on demo.icdevgroup.org  ... 

I did not experience any issues with my tests.

Do you use one of the following directives:

I assume having the above directives set will make a difference in how
session ids are handled.



More information about the interchange-users mailing list