[ic] IC 5.6.0 to 5.6.3 Post Form Fails with 500 Server Error

Gert van der Spoel gert at 3edge.com
Thu Apr 7 15:41:56 UTC 2011

> -----Original Message-----
> From: interchange-users-bounces at icdevgroup.org [mailto:interchange-users-
> bounces at icdevgroup.org] On Behalf Of IC
> Sent: donderdag 7 april 2011 18:25
> To: interchange-users at icdevgroup.org
> Subject: Re: [ic] IC 5.6.0 to 5.6.3 Post Form Fails with 500 Server Error
> >
> > Besides the error in weblogs there is no error in the local / global
> error
> > log?
> >
> > Did you upgrade your Perl in the mean time?
> > Which version of Perl do you use?
> >
> Hi Gert,
> I could find no error in the interchange, debug or catalog log file,
> apache
> error log showed premature end of script headers.
> This is a basic order profile, the order completes ok, spews out the
> emails
> and logs the order just fine but rather than getting bounced off to Paypal
> you just get a 500 server error, I have had to revert back to 5.6.0 while
> I
> try and work out why it no longer works.

Ok so the order processes and then this is the page it should bounce to
which then should kick in automatically the Paypal page submit.

Have you tried to simply put a page with input type="hidden"
name="first_name" value='FN' .... and for all fields some test values,
pricing test values and see if it submitted?

Then if that submits the [value fields are unlikely the suspects, but the
filter looks possibly an issue ... perhaps something doesn't like the
sprintf at this point .. 

So the quickest test would be to place an order yourself and hardcode a
price to see what happens.

Obviously you'll have to ask all your other customers to wait a moment with
placing their orders as you seem to be trying this with a 'live studio
audience' ...



More information about the interchange-users mailing list