[ic] Recently running cats on 2 IC installs failing

Mike Heins mike at perusion.com
Thu Aug 25 23:03:48 UTC 2011

Quoting IC Support (ic_support at mnwebdesign.com):
> Hi, I have 3 recently running catalogs failing on 2 different Interchange
> installations (low traffic settings) on the same server. One is 4.8.5 and
> one is 5.6. This seems to have happened after installing several Centos4
> package updates, including a perl update on my VPS which affected
> /usr/local/bin/perl. Have I already answered my own question or can anyone
> offer a place to start?
> Apache 2.2.19	PHP 5.2.17
> MySQL 5.5.14	Perl 5.14.1
> The 5.6 catalog is running old signals and appears to start fine, without
> errors in interchange.cfg, but sends browser a 500 Internal Server Error.
> Nothing of interest in debug.log. Catalog.cfg has this:
> c8bQIn9C: - [25/August/2011:16:32:07 -0500] 1982
> /cgi-bin/1982 Runtime error: Can't locate object method "func" via package
> "DBI::db" at /usr/local/lib/perl5/site_perl/5.14.1/i686-linux/DBD/mysql.pm
> line 227.

I can't help with that, but the other is a signal error. I would, in order
of preference for going back to where you were, 1) downgrade Perl back to 5.10
or less, or 2) don't set PERL_SIGNALS unsafe.

Mike Heins
Perusion -- Expert Interchange Consulting    http://www.perusion.com/
phone +1.765.328.4479  <mike at perusion.com>

"I find that a great part of the information I have was acquired
by looking up something and finding something else on the way."
-- Franklin Pierce Adams

More information about the interchange-users mailing list