[ic] Strange redirect behavior - only in Frefox

DB DB at M-and-D.com
Sun Jan 9 16:53:04 UTC 2011

> On 01/09/2011 11:28 AM, DB wrote:
>> Suddenly in the last day or two I'm seeing some odd behavior in both
>> catalogs running on my server. I've made no recent changes to the server
>> or to IC configuration.
>> If I click the link to the basket:
>> http://www.domain.com/ord/basket.html
>> Firefox 3.6.13 under XP shows an error:
>> "Firefox has detected that the server is redirecting the request for
>> this address in a way that will never complete."
>> Also if I log into the admin area, I get bounced to the admin login page
>> each time I click a link such as "content" or "tables"
>> I've rebooted my local machine and the server, and also cleared all
>> cookies and cache.
>> This seems to only happen in Firefox, not in IE or Chrome. Does anyone
>> recognize this behavior or have a suggestion about what may be wrong?
> It looks like you don't get a session assigned with Firefox. I would guess
> that the robot detection misfires, so check if you have the following
> entries in your robots.cfg:
> NotRobotUA <<EOR
>      AskTB,
>      Seekmo,
>      SearchToolbar,
>      MSIE,
>      Gecko,
> You need at least MSIE and Gecko.
> Regards
> 	Racke
> -- 
> LinuXia Systems => http://www.linuxia.de/
> Expert Interchange Consulting and System Administration
> ICDEVGROUP => http://www.icdevgroup.org/
> Interchange Development Team

Thanks - you were correct... my NotRobotUA section was horribly out of
date and correcting that cured my problem.

What I find very strange is that this behavior started just a couple of
days ago. FF has been using Gecko for quite some time now, no?


More information about the interchange-users mailing list