[ic] UTF-8?

Gert van der Spoel gert at 3edge.com
Fri Mar 25 18:18:13 UTC 2011

>>> Is anyone using the UTF-8 support in IC?  I'm realizing that
>>> non-English letters translated into my characterset can mess up
>>> certain parts of the system.
>>> - Grant
>> Hi Grant,
>> I am and the World has not come to an end yet (although with all recent
>> developments, I'm slightly getting worried ;)).
>> E-mails are not going 100% as they should yet with me, but I think that
>> misconfiguration (and lack of time) on my part ...
>> I experienced a drop in performance, working on migrating to more
>> hardware currently.
>> I started from scratch with UTF8 data, you will have a migration to do
>> probably on your data that up to now was not UTF8 ...
>> You'd most definitely first want to set it up in a staging environment
>> work out your migration steps before you blindly switch the environment
>> variables to work UTF8.
>> Good luck!
>> CU,
> Gert
> Thanks Gert.  It sounds like it should work end-to-end in a production
> environment with a little coaxing?
> - Grant

I'm running production so yes, but I strongly suggest you do not try to just
flip some catalog settings and convert your DB in production just like that.
I've been running UTF8-ish for the past 5 years, so when putting newer
versions of IC I already had the 'base' ready on UTF8 ... 

Oh I do suggest you take the latest IC version from git (nightly build), it
is pretty much about to be released and as stable as the previous versions +
some bugfixes.



More information about the interchange-users mailing list