[ic] {Spam?} Re: Re: Message: Attempt to order missing product code

Rick Bragg lists at gmnet.net
Fri Feb 10 17:19:18 UTC 2012

On Fri, 2012-02-10 at 15:57 +0000, Lars Weinrich wrote:
> >> Very often I can't store products in the cart. I use the same way to store a product, sometimes it works, and sometimes the next second it does not work.
> >> 
> >> In the error.log in the catalog-directory appears the following Message:
> >>  Attempt to order missing product code: [...]
> >> 
> >> I've traced the problem and sometimes (when the error occures) the Array $Vend::Cfg->{ProductFiles} is empty (and as a result the array @Vend::Productbase, too).
> >> When there is no problem the ProductFiles-Array contains 'products' and 'variants'.
> >> 
> >> Informations about the system:
> >>  Interchange V5.7.6
> >>  Perl v5.8.8
> >>  Linux (2.6.18-274.17.1.el5) 
> >
> >Does your cart just sometimes empty itself?  Maybe check to see if you have CookieDomain set? Does it happen between secure and non-secure pages?  Maybe you're loosing your session between these "servers?"
> >Rick
> The cart does not empty itself.
> All request are non-secure. CookieDomain is not set. Is it relevant when the problem occurs only on non-secure pages?
> Lars

Take a look at html source of the page with the form button you are
clicking on when you add items. Is this the flypage? or a search results
page?  Make sure there is a valid sku in that form.  If there is, then
it's in the process that adds the item to the cart, if not, then it's in
way the form is being made on that page.  

More information about the interchange-users mailing list