[ic] Simple if, why doesn't this work?

Mark Overmeer mark at overmeer.net
Wed Jul 17 20:02:17 UTC 2013

Dear list,

I have spend a few hours in attempt to understand why this is not
working, and I have not clue.  Could be very obvious to an gifted
IC developer.

A form has a radiobutton list.  I try to fork between the four options, 
with the following code (including debug info)

        PAYNOW=[cgi paynow]<br>
        PAYMETH=#[cgi paymethod]#<br>

        [if cgi paynow]
          PAYNOW1=[cgi paynow]<br>
          PAYMETH2=#[cgi paymethod]#<br>
          [value name="mv_order_route" value="log" hide=1]

        %0 [cgi paymethod] %
          [if cgi paymethod eq sofort]
            [value name="mv_order_profile" value="sisow" hide=1]
        SOFORT = [cgi paymethod]<br>

        %1 [cgi paymethod]%
          [if cgi paymethod eq ideal ]
            [value name="mv_order_profile" value="sisow" hide=1]
        IDEAL = [cgi paymethod], [cgi ideal_bank]<br>

        %2 [cgi paymethod]%
          [if cgi paymethod eq paypal ]
            [value name="mv_order_profile"       value="paypal" hide=1]
            [value name="pp_use_billing_address" value="0"      hide=1]
            [xbounce paypalsetrequest]

        %3 [cgi paymethod]%
          [if cgi paymethod eq vorkasse ]
        VORKASSE = [cgi paymethod]<br>

Now, only paymethod="sofort" works.  It does not matter whether that
if-block is at the top of the four, or anywhere else.  All other
three options do never show their text!  I have tried quotes around
the keywords, eq -> =  The do show the right value in the debug lines

Thanks in advance,


       Mark Overmeer MSc                                MARKOV Solutions
       Mark at Overmeer.net                          solutions at overmeer.net
http://Mark.Overmeer.net                   http://solutions.overmeer.net

More information about the interchange-users mailing list