[ic] cPanel Officiallly "Dumping" Interchange?!

Alan Cook acook at southside-studios.com
Wed Jun 12 15:58:40 UTC 2013

My hosting partner notified me today of errors he was receiving from the web
server. It seems cPanel is refusing to update itself if Interchange is
installed - even though it is *not* their old borked version. Has anyone
else encountered this?

The pertinent lines in the error log/emails are:

Subject: Cpanel version change is blocked
fatal,Cannot upgrade because Interchange is installed.


An error was detected which prevented updatenow from completing normally.
[20130612.023944] E Blocker found: Cannot upgrade because Interchange is
[20130612.023944] ***** FATAL: An attempt to up/downgrade to was
blocked. Please review blockers.
[20130612.023944]   The Administrator will be notified to review this output
when this script completes
[20130612.023944] E Detected events which require user notification during
updatenow. Will send iContact the log

The host contacted cPanel support, and received this response:


Your current version is 11.36, and according to our long-term support
documentation, we will offer support for it until January 2014:


Regarding Interchange, there are many open-source third party shopping carts
that do what Interchange did, and are more up to date. We don't officially
recommend any particular one, however.

Please let me know if you have any questions.

Thank you.

Forest Kistner
cPanel, Inc.
Technical Analyst

Alan Cook
Southside Studios

More information about the interchange-users mailing list