[ic] Problem after OS ... (Solved)

Boyd Lynn Gerber gerberb at zenez.com
Thu Feb 12 17:23:41 UTC 2015


On Thu, 12 Feb 2015, Peter wrote:

> On 02/12/2015 05:52 PM, Boyd Lynn Gerber wrote:
>> Failed to record timestamp in UserDB: DBD::mysql::st execute failed:
>> Incorrect datetime value: '1423715746' for column 'mod_time' at row 1 at
>> /usr/local/interchange/lib/Vend/Table/DBI.pm line 1741.
> That looks like unitime (seconds after epox) and represents the date,
> "Thu Feb 12 04:35:46 2015 UTC".  Mysql doesn't recognize unixtime as a
> valid input format for datetime formatted fields, hence the problem
> you're having.  In this case you must have either changed the table
> schema for that column from something like varchar to datetime, or
> changed  code in Interchange that was supposed to translate that
> timestamp to a value accepted by mysql.
> See http://dev.mysql.com/doc/refman/5.7/en/date-and-time-literals.html
> for a description of supported time formats in mysql.
> The easiest (but not necessarily the best) solution here to just get
> your catalog working again is probably:
> ALTER TABLE userdb MODIFY mod_time VARCHAR(20);

Thanks, That worked for now while I figure out why it suddenly stopped 
working.  To test everything, I rebuilt the version of perl being used. 
Tested and installed it. rebuilt the version of IC it was using.  Compare 
it to what was being used.  Only object or executealbes were different. 
Made sure all the individual catalogs were the same.  Some where IC must 
have been changing unixtime or was getting the information a different 
way.  For no I have thngs running while I figure it out.


Boyd Gerber <gerberb at zenez.com> 801 849-0213
ZENEZ   1042 East Fort Union #135, Midvale Utah  84047

More information about the interchange-users mailing list