Andrew Baerg andrew at pullingshots.ca
Tue Aug 16 06:08:19 UTC 2016

On 2016-08-12 12:07 PM, Josh Lavin wrote:
> Quoting Matthew Klassen (matt at yoursole.com):
>> I did actually try to 'make install' with the failures, and everything looks
>> fine, until you start and you get 'No sockets -- INTERCHANGE SERVER
>> I've now tried setting up perlbrew with both 5.22.2 and 5.24.0, but I end up
>> with the exact same failures on the Interchange install.
> Good to know. So it must not be Perl related.
>> I forgot to mention we are using Interchange 5.7.6
> I think you should try the latest from Git like David suggested -- build
> with the notes from the README-DEVELOPMENT file. If that doesn't make a
> difference, it must be something peculiar to your architecture.
> Best,
> Josh 

This is solved!

The issue had to do with creating the socket files on the vagrant shared project folder. I think the filesystem, vboxsf, causes issues with the sockets.

The solution was simply to compile, test, and run the Interchange server from /home/vagrant.

Thanks everyone!


https://github.com/pullingshots ... https://metacpan.org/author/BAERGAJ

More information about the interchange-users mailing list