[ic] UTF-8-issue

David Christensen david at endpoint.com
Tue Dec 6 15:50:38 UTC 2016

> On Dec 5, 2016, at 6:22 PM, Peter <peter at pajamian.dhs.org> wrote:
> On 06/12/16 13:02, René wrote:
>> Hi folks!
>> I stumbled into a new Internal Server Error when exporting tables via
>> the admin-ui. I got the following error in the log:
>> admin/export_table Runtime error: Undefined subroutine
>> &Vend::CharSet::is_utf8 called at
>> /usr/local/interchange/lib/Vend/CharSet.pm line 61
>> This time the reason was a forgotten "export MINIVEND_DISABLE_UTF8=1" in
>> my init-script. Removing that line fixed it. Users upgrading with
>> MINIVEND_DISABLE_UTF8 set will most likely get the same error if not
>> removing this setting..
> More to the point is_utf8 is explicitly not exported to Vend::CharSet if
> MINIVEND_DISABLE_UTF8 is set, which suggests that in this case
> export_table should not be attempting to call is_utf8.
> I think we may run across this on occasion and as such it might make
> sense to put in a stub is_utf8 function that always returns false when

Which IC version are you using?  I’d found and fixed a few issues with this recently, so if you’re using 5.10 and not HEAD you might consider upgrading.  Otherwise, I may have missed some spots.

David Christensen
End Point Corporation
david at endpoint.com

More information about the interchange-users mailing list