[ic] TLS upgrade

Jon Jensen jon at endpoint.com
Fri Sep 22 02:22:21 UTC 2017

On Thu, 21 Sep 2017, David Etheredge wrote:

> Is interchange currently enabled for TLS 1.2 ?  We received the 
> following notice: ensure you are no longer using TLS 1.0 or 1.1 prior to 
> September 18th 2017.

Interchange itself doesn't do TLS -- that's a function of your web server 
(often Apache httpd), your Perl libraries (for LWP, etc.), your system 
libraries curl, wget, and openssl.

The first thing to consider is your server OS and OpenSSL libraries. I 
wrote about this a couple of years ago:


If you're using an unsupported distribution such as RHEL 5, CentOS 5, 
Debian 6, or Ubuntu before 12.04, you probably don't have TLS 1.2 support, 
and have other security problems on such an OS.


Jon Jensen
End Point Corporation

More information about the interchange-users mailing list