delionsweb - minivend minivend@delionsweb.net
Wed, 22 Nov 2000 10:20:44 -0500


Some advice (probably won't solve your problem but consider it a 'best 
practices' type thing) and some questions:
1. Don't unzip in public_html. Do it in the home dir itself i.e. 
2. At what point do you get the error? (Be specific i.e. after the n-th 
prompt i.e. "Where did that happen?")
3. The error messages tend to indicate that you userid does not have read 
permissions on the parent directory(ies) of your home directory. As far as 
I can tell FindBin is only used to determine the directory that the 
Makefile.PL program is in and then make that the current directory for the 
execution of Makefile.PL.
You might try to modify Makefile.PL like this
Comment out the BEGIN statement at line 4 like this:
#        eval {
#                require FindBin;
#                chdir $FindBin::RealBin;
#        };
and then be VERY sure to run the ./configure or perl Makefile.PL when the 
/user21/home/bigdaves/interchange-4.6.0 directory is the current directory.
If you use the perl Makefile.PL and it works then you'll have to do these next:
make test && make install

OK, that should give you something to chew on for now ...

At 09:36 AM 11/22/2000, you wrote:
>My name is David Stites.  I downloaded the latest version of interchange
>(4.6.0) in tarball format.  I run a UNIX FreeBSD server and I uploaded the
>tarball to my public_html and I unzipped it.  I chdir into the interchange
>directory and I try to run the ./configure @ the command line.  However I
>get an error.  I try to run the perl Makefile.PL and I get the same error.
>I have all the system requirements (perl and DB).  I also tried uploading it
>to my root (/user21/home/bigdaves/ and I got the same error.