[ic] Broken Image

Mike Heins mikeh@minivend.com
Sat, 7 Oct 2000 09:25:41 -0400

Quoting Mathew Jones (matjones@booksellersolutions.com):
> Hi,
> I posted this to the list a while ago but got no response.
> When I import new records into my database using the UI, it has a
> strange effect on the image column in my database. AFter importing I go
> to my  catalog and search for the product i just entered. It pulls up
> all the information, but also shows a broken image, even though there is
> no imagename in the image field.
> If i go view that item using the UI there is nothing in the image field.
> When I click on ok, and go back to my store. The broken image
> disappears. Now this isnt too troublesome for 1 broken image but when I
> do imports of hundreds of items this becomes a problem. I did find that
> I could also get rid of these broken images by using a mysql interface
> and issuing the command
> UPDATE products SET image="" WHERE image =""
> It really makes no sense that on import something gets hidden in that
> last image field. Could it be the way my products.mysql is set.
> Has anyone experienced this problem?? Could someone help. If you need
> access to my store to see what i'm talking about please let me know.

I wonder if it is getting set to NULL. Is the field defined as NOT NULL?

Akopia, Inc., 131 Willow Lane, Floor 2, Oxford, OH  45056
phone +1.513.523.7621 fax 7501 <heins@akopia.com>

I have a cop friend who thinks he ought be able to give a new ticket;
"too dumb for conditions".