[ic] Can't see New Tables in admin interface

Ed LaFrance edl@newmediaems.com
Mon, 26 Feb 2001 09:36:45 -0800

At 11:01 AM 02/24/2001 -0500, you wrote:

>>This is my first message.. I'm a bit nervous :)
>>I have created a Table named "marcas" in the database. It's almost all
>>fine with that, except that I cannot modify or insert new records. Just
>>delete them (????). I can see this table in the admin.
>>Then, I tried to create another table named "ultima". It worked fine.
>>Interchange created the table as defined, but I can't see this table in
>>the list of table of the admin.
>>Well I did a 3rd try with another table, but I still can't see it. I know
>>it's created and I can insert and delete records from a web mysql admin,
>>but not from the interchage admin interface.
>>Well if anybody knows what can be happening, please tell me :)
>>I'm using mysql... any hints ?

I don't have an answer for you but I will throw in my observations.  I have 
seen this on one installation of IC 4.6.0 on an RH7 box.  In their case, 
they were running the Interchange server as a different user than the 
catalog in question...and this was the only immediately apparent difference 
between their installation and countless others I have done/seen which do 
not exhibit this problem.  I requested that they install either another 
instance of IC or a copy of the catalog in such a way as to make the server 
and catalog under one user, just as an expirement.  I have not heard from 
them as to whether or not this was done.

I don't know if they did the tarball install or RPM - I use the former 
almost exclusively.  I am assuming that you set the table up correctly in 
Interchange (dbconf/mysql/tablename.mysql for the table defs, and the text 
source file tablename.txt in the products directory) and that you saw the 
table creation messages on the command line or in the logs.

- Ed L.