[ic] error in Configure: Bareword "GDBM_NOLOCK" not allowed while "strict subs"

Ed LaFrance edl at newmediaems.com
Tue Dec 23 11:06:21 EST 2003

At 08:06 AM 12/23/2003 -0500, you wrote:
>Am running into this error  & cannot get by it in an attempt to upgrade
>from 4.9.8
>Manifying blib/man1/offline.1
>PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
>-I/usr/lib/perl5/5.6.0/i386-linux -I/usr/lib/perl5/5.6.0 test.pl
>server/unixmode.......Bareword "GDBM_NOLOCK" not allowed while  "strict
>subs" in use at /root/interchange-5.0.0/blib/lib/Vend/Table/GDBM.pm line
>Compilation failed in require at blib/script/interchange line 215.
>BEGIN failed--compilation aborted at blib/script/interchange line 239.
>not ok 1
>I have done both Bundle::interchange to it's full extent and
>Bundle::Interchange5 to it's full extent.
>Any ideas are appreciated
>C.B. Currier

I can confirm this - I have not had a chance to run it by the other 
developers, but it appears that IC 4.9.9 and up require a higher Perl 
version than 5.6.0 (implicitly at least), and in fact this may even be in a 
README file in the dist directory somewhere. Building a new non-threaded 
Perl from the latest release and installing all the needed modules, then 
installing/running interchange 5.0 off of that instance of Perl is the fix.

- Ed

New Media E.M.S.              Technology Solutions for Business
11630 Fair Oaks Blvd., #250   eCommerce | Consulting | Hosting
Fair Oaks, CA  95628          edl at newmediaems.com
(916) 961-0446                http://www.newmediaems.com
(866) 519-4680 Toll-Free      (916) 961-0447 Fax

More information about the interchange-users mailing list