[ic] Account details does not check for errors...

Matthew Crosswell matthew at compedge.co.nz
Thu Jul 10 22:54:46 EDT 2003

I am not sure what I have done to my account application form, current
behaviour is that it does not return to the page with the errors highlighted
but instead goes straight to the page specified in mv_nextpage. Should I be
bouncing the page based on some returned value?

If anyone could plese help me with how to set up a multipaged account
application form I would really appreciate it.

Matthew :)

Environment : (IC4.9.8 and MySQL Perl5.8 on RH9)

Snippets of code:

--> This is the mv_nextpage .... it works just seems to skip the checks but
upon revisiting the page the required fields are marked in red.....

<INPUT TYPE=hidden NAME=mv_nextpage VALUE=[if scratch agent_type ==
2]account_doctor[elsif scratch agent_type ==
3]account_hospital[/elsif][elsif scratch agent_type ==

--> This is the form setup block....
<FORM ACTION="[process secure=1]" METHOD="POST" NAME="ACCOUNT">
<INPUT TYPE=hidden NAME=mv_session_id VALUE="[data session id]">
<INPUT TYPE=hidden NAME=mv_order_profile VALUE=account_change>

[if type=explicit compare="[error all=1 show_var=1 keep=1]"]
  <b>There were errors in your last submission.</b>
  They are shown in <FONT color="red">this color</FONT> below.</FONT>

[comment] account_change profile in etc/profiles.order [/comment]
<INPUT TYPE=hidden NAME=mv_todo     VALUE=return>
<INPUT TYPE=hidden NAME=mv_nextpage VALUE=@@MV_PAGE@@>
<INPUT TYPE=HIDDEN NAME=mv_check    VALUE="Save_database">

[set Save_database]
[userdb save]

--> This is my submit button (there are actually three of them each going to
a different page of the account application process)......

      alt="Save Account details"

More information about the interchange-users mailing list