[ic] Problems installing interchange 4.9.8 on Suse 8.2

Lyn St George lyn at zolotek.net
Tue Nov 4 19:40:24 EST 2003

On Tue, 4 Nov 2003 20:18:27 +0100, Martin Ascherl wrote:

>I have installed Interchange 4.9.8 (tar-archive) on my Suse 8.2 system.
>I have not-thread-enabled perl installed (v5.8.0) and most recent
>version of Webmin 1.10.
>I installed DBI and DBD::mysql with following perl commands:
>perl -MCPAN -e 'install DBI'
>and then,
>perl -MCPAN - 'install DBD::mysql' 
>Both are up-to-date.
>When I go to /usr/local/interchange/bin
>and try to start the interchange server with ./restart
>I got the following message :
>Interchange server was not running (/usr/local/interchange/etc/interchan
>Low traffic settings.
>Calling UI......UI is loaded...
>Interchange V4.9.8
>Configuring catalog foundation...Required Perl module DBD::mysql not
>Aborting catalog.
>In line 2 of the configuration file 'dbconf/mysql/mysql.cfg':
>foundation config error: Required Perl module DBD::mysql not present.
>Aborting catalog.
>In line 2 of the configuration file 'dbconf/mysql/mysql.cfg':
>foundation: error in configuration. Skipping.
>foundation: config error. Skipping.
>Interchange server started in UNIX mode(s) (process id 13549)
>Can anyone tell me why ?? Please advice.

You probably have 2 installations of perl - one being the original
one by Suse, and the second your own installation. One would be
in /usr/bin, the other in /usr/local/bin and the #! line in the interchange
files is pointing to the wrong one. 

>I also tried to install the perl module bundle::Interchange and
>both with the error message:
>Failed to install module : Not a valid Perl module 

Case sensitivity:  'install Bundle::Interchange5'

>Thanks in advance for any help. 

Lyn St George
+ http://www.zolotek.net .. eCommerce hosting, consulting

More information about the interchange-users mailing list