[ic] Undefined catalog error

Peter peter at pajamian.dhs.org
Sun Nov 30 03:55:04 EST 2003

Peter wrote:
> IC version 4.9.9 installed from RPMs onto RedHat 7.3 server with Apache 
> 1.3.27, postgresql v 7.3.4.
> I ran makecat and all went fine except I had to run the createdb command 
> manually so I could specify the -U switch in it.  I started IC with 
> /etc/init.d/interchange start and it started right up.
> I get the following error on the catalog I just created:
> Undefined catalog: /cgi-bin/madame-s
> The foundation demo, installed from the foundation-demo RPM runs fine, 
> though.
> Any help on why it thinks the catalog is /cgi-bin/madame-s rather than 
> just madame-s (as I would believe it should be)?  Is this a bug or is 
> there something I did wrong in the setup?

Never mind, I got it working, though if someone wants to comment it 
would be nice just for the archives for someone searching who has the 
same problem (and for my own curiosity).

Anyways, it was an ownership problem.  When I ran makecat I had selected 
apache for the CatUser, I re-ran makecat and selected interchange for 
the CatUser and it works fine now.

What I would like some explanation of, if someone can, is why would 
selecting the wrong owner cause that particular error message?  and 
shouldn't there be a better error message for it that gives some kind of 
clue as to the real problem?

Thanks, Peter

More information about the interchange-users mailing list