[ic] Start Interchange 5.0.0-1.9 in RH9

Mike Heins mike at perusion.com
Tue Jan 13 13:26:07 EST 2004

Quoting Paulo Moniz(Inteliware.net) (paulo.moniz at inteliware.net):
> Hi,
> 1. I installed RH9 in a P4 3GHz HT.
> 2. As root installed a non-threded perl version in /usr/local (see perl
> -V below)
> Op/fork failed but still I installed perl
> 3. As root installed all modules OK -> /usr/local/bin/perl -MCPAN -e
> 'install Bundle::Interchange'
> 4. As root RPM could not check dependencies so I did OK -> rpm -Uvh
> --nodeps interchange-
> 5. Same for Foundation and Demo RPMs
> But,
> I cannot start interchange as root or interch using '/sbin/interchange
> -restart' or '/etc/rc.d/init.d/interchange restart'.
> No error messages appear on prompt and /var/log/interchange/error.log is
> empty
> Tried to reboot and ... Nothing
> My apache root is /home/httpd/vhosts/default/htdocs

You need to edit /usr/lib/interchange/bin/* to use /usr/local/bin/perl
in the first (shbang) line.

Mike Heins
Perusion -- Expert Interchange Consulting    http://www.perusion.com/
phone +1.765.647.1295      <mike at perusion.com>

I have a cop friend who thinks he ought be able to give a new ticket;
"too dumb for conditions".

More information about the interchange-users mailing list