[ic] mod_interchange and Apache 2.0

Mike Heins mike at perusion.com
Sun Jun 27 12:22:39 EDT 2004

Quoting Sean Benton (IC at neurometrics.net):
> Hello all this is my first post so be kind :)... hopefuly usefull to 
> some out there..
> >Problem Notes
> >-------------
> >This isn't just something that happens with the options table either. It
> >happens when I try to delete a record from any table using the Table
> >Manager (flex_select and family) or the Item Editor.
> >
> >However, if I have /cgi-bin/speedquest in the CGI_URL variable,
> >everything works fine. Even if I still have RewriteEngine on for that
> >domain. The rest of the Admin UI works fine. It seems to be just when
> >I'm trying to delete a record from a table.
> >
> >Is there something specific to that part of IC that needs to have a
> >RewriteRule specified?
> >
> >Also, I get nothing in any error logs when this is attempted.
> >
> >I hope someone can help.
> What is actualy happening is that the session ID is being lost, and has 
> realy nothing to do with the Apache directive
> RewriteRule, more to do with blanking the CGI_URL directory varible as 
> the testing that I did concluded some info was being lost as a result of 
> changing this .


You are correct. Both changes are made in CVS now.

I am the guilty party on this -- I far too often fail to include the
session ID in forms. I will try to do better.

Thanks for finding these!

Mike Heins
Perusion -- Expert Interchange Consulting    http://www.perusion.com/
phone +1.765.647.1295  tollfree 800-949-1889 <mike at perusion.com>

Being against torture ought to be sort of a bipartisan thing.
-- Karl Lehenbauer

More information about the interchange-users mailing list