[ic] Admin Page Keeps Logging Out

Alan Cook acook at newagedigital.com
Fri Feb 25 10:50:35 EST 2005

Hello all,
I'm toying with making admin pages and am having an odd problem.
Here's what happens:

The form shows fine (listing categories).
When posted, I get a list of images in the category.
Anything else clicked after that goes to the login.
The mv_session_id seems to carry over fine, and I'm rather stumped...

The page is a modified copy of admin/content.html.


[set page_title]Image Gallery[/set]
[set ui_class]Content[/set]
[set icon_name]icon_pages.gif[/set]

<!-- ----- BEGIN REAL STUFF ----- -->

<form method="post">
<input type=hidden name=mv_session_id value="[data session id]">

[if scratch ui_error]
<blockquote class=cerror>
[scratchd ui_error]

[warnings auto=1]

[if type=explicit compare="[error all=1 show_var=1 keep=1]"]
<B>[L]The following errors occurred:[/L]<br>
<blockquote class=cerror>
        [error all=1 keep=1 show_error=1 show_label=1 joiner="<br>"]
[query type=list sql="SELECT DISTINCT category FROM photogallery"]
        [on_match]<select name="selcat">[/on_match]
        [no_match]No Categories in gallery.[/no_match]

        [list]<option value="[sql-param category]">[sql-param

        <input type="Submit" value="Load Category" />


<br clear="all" />

[if cgi selcat]
        [query type=list sql="SELECT * FROM photogallery WHERE category
= '[cgi selcat]'"]

        [table-organize cols=4 pretty=1]
                        <TD align="center">
                        <a href=[area href=@@MV_PAGE@@
form='selcat=[sql-param imgid]']
                        ><img src="[sql-param thumb]" /></a><br />
                        <font size="-1">[sql-param thumb]</font>

<!-- ---- END REAL STUFF ---- -->
<!-- page: @@MV_PAGE@@ -->

More information about the interchange-users mailing list