[ic] Strange Authnet behavior please help

Bill Jordan bill.jordan at crystalcreations.com
Tue Jul 12 00:52:16 EDT 2005

I am in the process of setting up a new server and am having real
trouble with ic and auth net. Used ic 4.8.6 with auth net forever on the
old box with little trouble. here's the skinny:

redhat 3.0 ES with perl 5.8.6 ( built it myself without threads )
I am getting the same errors whether i use interchange 4.8.X, 4.9.X, 5.2
( target version ) and even ic 5.3 . Authnet version is 3.1 and i am
using standard foundation checkout pages ( no cvv info)
I am including the Vend::Payment::AuthorizeNet line in my interchange
config file
I have the following set in catalog.cfg:

Variable   MV_DEMO_MODE      0
Variable   MV_PAYMENT_MODE      custom authorizenet
Variable   MV_PAYMENT_ID         myid
Variable   MV_PAYMENT_SECRET    mypasswd
Variable   MV_PAYMENT_HOST      secure.authorize.net
Variable   MV_PAYMENT_REFERER   http://myurl

In this config I get "Bill to country is required" back from authnet.
if I change MV_PAYMENT_MODE to authorizenet instead of custom
authorizenet then it tells me i have an invalid account or password.

I have tried including the globalsub in interchange.cfg ( the old way)
and it makes no difference.
I have tried export PERL_SIGNALS=unsafe -- no effect
I have tried playing with and even deleting my referring url in both the
catalog and authnet -- no effect

I must be missing something pretty basic here, I even tried to get an
old 4.8.6 setup working and it is acting the same way. I have been
banging my head against this for 4 days now and my next stab is going to
be downgrading my perl to 5.6.1 and trying again, but if someone
recognizes these symptoms or has an idea i have missed, please please
please let me know, site is eating dollars while it is down.

More information about the interchange-users mailing list