[ic] We're sorry, the Interchange server is unavailable

Peter peter at pajamian.dhs.org
Thu Jun 16 07:41:35 EDT 2005

On 06/16/2005 04:16 AM, Ulf Holt wrote:
> Dear Davor,
> Sorry for a late reply - the server is at my office, and I did't see
> your reply until I came home yesterday evening.
> I have checked one zillion articles about this issue, but looks like I
> haven't found the one describing a solution to my problem (if this
> article exists). All configuration files looks good. Intechange IS
> running. I tried to start interchange from user interch in debug mode:
> ./interchange --debug
> Low traffic settings.
> Calling UI......UI is loaded...
> Interchange V5.2.0
> Configuring catalog foundation...Using default DBM database...done.
> Configuring catalog smykkeshop...Using PostgreSQL,
> DSN=dbi:Pg:dbname=smykkeshop...done.
> Interchange server started in UNIX mode(s) (process id 3563)
> Have also checked /var/log/interchange/error.log - which indicates no
> problems.
> Wonder if this might be a perl problem - though I am running unthreaded
> version of perl in /usr/local/bin.
> Have also tried to build interchange from the tarballs and started a
> separate process - same problem.

check your link files and make sure they have the suid bit set:

ls -la /var/www/cgi-bin

You should see the link files listed (foundation and smykkeshop), check 
the series of letters to the left, you should see an 's' as one of them, 
if you don't then issue the following commands (as interch or as root):

cd /var/www/cgi-bin
chmod u+s foundation smykkeshop


More information about the interchange-users mailing list