[ic] Upgrade to latest CVS and on catalog is getting a problem...

Stefan Hornburg racke at linuxia.de
Tue Aug 29 15:32:57 EDT 2006

Boyd Lynn Gerber wrote:
> Hash: SHA1
> I just upgraded from 5.4.1 to the latest CVS and I am seeing a issue when
> starting interchange.  Everything worked just fine for a day, then late
> last night I got this on a restart.
> Sending debug messages to debug.log.
> Low traffic settings.
> Calling UI......UI is loaded...
> Interchange V5.5.0
> Running with new signals, external programs could be unreliable.
> Configuring catalog americasindust...Using MySQL,
> DSN=dbi:mysql:americasindust...Database products scalar parameter KEY
> redefined to 'sku', was sku.
> Database products scalar parameter HIDE_FIELD redefined to 'inactive', was
> inactive.
> done.
> Configuring catalog bus...Using MySQL, DSN=dbi:mysql:bus...done.
> Configuring catalog can...Using MySQL, DSN=dbi:mysql:can...done.
> Configuring catalog mat...Using MySQL, DSN=dbi:mysql:mat...done.
> Configuring catalog rat...Using MySQL, DSN=dbi:mysql:rat...done.
> Configuring catalog standard...Using MySQL,
> DSN=dbi:mysql:test_standard...done.
> Configuring catalog usindust...Using MySQL, DSN=dbi:mysql:usindust...done.
> Interchange server started in UNIX mode(s) (process id 25113)
> This happened after a interchange sever restart.  I then shutdown the
> machine and rebooted.  I still get the error.  I have droped the products
> table and used a blank one...  (That is one without any items just the
> titles from the standard demo from the CVS and it still complains.)  I am
> not sure how to stop this message from being reported.  The catalog seems
> to work just fine but I really want to stop getting this error.  Any
> ideas?  I also backuped my Database and tried to start from a blank
> standard demo and the error persists.  I created a new catalog and I do
> not get the error with it.  Any ideas on what triggered the error.  The
> logs do not show any error.

You have defined the KEY/HIDE_FIELD parameters twice in your catalog.
Both values are identical, so there is no error. Presumably grep will
reveal the location of the definitions.

With regards

LinuXia Systems => http://www.linuxia.de/
Expert Interchange Consulting and System Administration
ICDEVGROUP => http://www.icdevgroup.org/
Interchange Development Team

More information about the interchange-users mailing list