[ic] $tag->add_item

Adam Lambert tech at khouse.org
Wed Nov 14 20:01:01 EST 2007

    So, as the Christmas season rolls around, my boss asks me to
uncomment the usual Christmas code, and plug in a given list of SKU's
for this year's specials.   All well and good, except for the
following.  The code I inherited from my predecessor is doing the following:

if($Scratch->(xmas_special)) {
    // set some variables - this all works, right up until:
    $Tag->add_item( { code => $Scratch->(xmas_sku), qty => 1 } ) ;

    There's more to it than that, but that's enough to explain my
problem.   I get a whole bunch of the following in my debug logs, and
the item(s) in question never get added to the cart:

   "process Tag 'add_item' not defined."

    All I can say at this point is, it worked last year, and I don't
know enough about Interchange to have clue one where to start figuring
out why this no longer works.   I'm pretty sure they upgraded
Interchange to a newer version after this code bit was removed from
production (end of last Christmas season), and I'm the new guy in charge
of all this (without benefit of my predecessor to ask questions of), and
scratching my head wondering how I'm going to get this working by
Christmas, given that I have no idea where to start.   My conclusion - I
need help from you kind folks!  :)

    So, if you can, help me out here - I would greatly appreciate it. 
And let me know if any further debug info is needed/required, and I'll
see what I can do.  I'm also available to catch up on #interchange on
IRC if someone is willing to help me - would be faster than swapping


Adam Lambert
Koinonia House, Inc.
adam at khouse.org

More information about the interchange-users mailing list