[ic] Problem with blank_label

Rick Bragg lists at gmnet.net
Tue Apr 22 00:18:05 UTC 2008

On Mon, 2008-04-21 at 12:08 -0600, Shirley Studebaker wrote:
> Sorry for the repeat post but I am stuck on this one problem and can't  
> move forward until I solve it...
> We are using Interchange 5.2.0.
> I am building item options based on the color(sku) selected and want  
> the first option to be "select size". Here is the code I am using:
> <div id="opt_container" style="position:relative; width:200">
> 	[loop prefix="item" search="co=yes/fi=products/se=beachCollar/ 
> sf=subcat/se=Collar/sf=category/tf=unused"]
> 		<div id="opt[item-field sku]" style="position:absolute; z-index:1;  
> left: 0px; top: 0px; width:200; visibility: visible">
> 			[table-organize cols=2 table=' ' pretty=1]
> 				[item-options td=1 bold=1 blank_label="select size"]
> 			[/table-organize]
> 		</div>
> 	[/loop]
> </div>								
> The blank_label call in item-options seems to do nothing.
> There is an example page at http://www.tailwags.com/cgi-bin/tailwags/TWBeach3.html 
> . I am calling the blank_label on the size for the collars. I REALLY  
> need this part of the code to force the customer to make a selection.
> Thanks for any help you can give me.
> Shirley

I'm not sure if this will help, or if I understand the problem totally,
but I have done this in the past...  


     SELECT * FROM `variants`
     WHERE `sku` = "[item-code]"
     ORDER BY `code`
    <select name="mv_sku">
      <option value="">--Select Size--</option>
      <option value="[variants-code]">[variants-field description] ([variants-field price])</option>

More information about the interchange-users mailing list