[ic] Cannot start interchange

Rick Bragg lists at gmnet.net
Wed Jul 2 04:37:54 UTC 2008

On Tue, 2008-07-01 at 17:39 -0400, Mike Puntolillo wrote:
> I am a new Interchange user and have been having an awful lot of trouble 
> setting it up. I complied from source, ran makecat, and when I run 
> ./interchange I get no errors. When I attempt to access Interchange from 
> firefox I get "
>        We're sorry, the Interchange server is unavailable...
> We are out of service or may be experiencing high system demand. Please 
> try again soon.
> "
> If i try ./interchange -r I get "The previous Interchange server was not 
> running and probably terminated with an error." The server was running, 
> however, because I saw it when I ran ps -e. The error.log does not give 
> any additional information.
> I installed interchange from source on OpenSuse 11.0 x86_64. I am using 
> apache as the web server. My firewall is disabled. Perl is using threads 
> but it is version 5.10 and I am all out of ideas. Can someone please help?
>       Thanks,
>        Mike

Did the makecat finish OK? - makecat should have finished with a message
something like "You are now ready to run your catalog, please put
something in your cron to expire old session stuff." (I forgot the exact
message but it is something like that...) 
Are you using UNIX mode or INET mode?
When you started IC right after makecat, did it build the database OK?
Take a look at your catalog error.log, and the IC error.log Let us know
what is says.


This message has been scanned for viruses and
dangerous content by Green Mountain Network, and is
believed to be clean.

More information about the interchange-users mailing list