[ic] javascript with 5.5.2

Sales Dept sstreich at hughes.net
Thu Mar 13 10:02:11 EST 2008

----- Original Message ----- 
From: "Kevin Walsh" <kevin at cursor.biz>
To: <interchange-users at icdevgroup.org>
Sent: Thursday, March 13, 2008 1:03 AM
Subject: Re: [ic] javascript with 5.5.2

> "Sales Dept" <sstreich at hughes.net> wrote:
>> I moved the script to the apache root folder and still received the same
>> error Sorry, the page (js/script1.js) was not found. I then tried the
>> <script type='text/javascript' src="[area href='js/script1.js']" 
>> </script>
>> again the same error.
>> I am using the mod_interchange module on this server which I am not on 
>> the
>> 5.3 server.
>> The javascript program I am trying to use is opencube's Quickmenu V6.3
>> Nothing is showing in any of the logs to indicate what the problem is.
> If you need Apache (with mod_interchange) to serve the file then do this:
>    1. Create a directory called "js" in Apache's DocumentRoot and put
>       your script in there.
>    2. Add /js/ to mod_interchange's OrdinaryFileList directive in your
>       Apache configuration.
>    3. Restart Apache if you changed the config for #2.
>    4. Use <script type="text/javascript" src="/js/script1.js"></script>
>       in your HTML's <head> section.

All I can say is a REALLY BIG THANK YOU !!
That's all it was. Adding to the Filelist was the answer.
Doing step 4 placed the script up in the logo area, so I moved it down to 
the menu bar area in variables/common_menu to test it, is this going to 
effect the sessions or anything else I should be aware of.
Again thanks- I was getting suspicious it may be mod_interchange which is 
why I mentioned that.

More information about the interchange-users mailing list