[ic] Updating Vend Safe to make interchange compatible with new versions of perl

Peter peter at pajamian.dhs.org
Wed Feb 6 22:55:55 UTC 2013

On 07/02/13 08:53, Peter Motschmann wrote:
> Recently my company has begun the process of migrating from perl v5.10.0
> to v5.14.1. This caused all sorts of mayhem; the short version of a two
> day investigation in to why all manor of random unseemly related things
> broke is that Interchange does not work well with newer versions of Safe.

Wow, I always thought it was newer versions of Perl that was breaking
it, not Safe itself.  That has caused some confusion and I really
appreciate that you've found the real problem here.

> Integrate an older version of Safe directly into Vend::Safe

That's a very good idea.

> https://gist.github.com/pmotschmann/4723986

I think we should go ahead and pull this change into the core now but I
also think it would be good to find out exactly what is causing the
issue in Safe itself, and maybe we can fix the regression and get a
patch out to the maintainers of Safe so that future versions will work


More information about the interchange-users mailing list