[ic] considering an upgrade from 5.5.1

David Christensen david at endpoint.com
Thu Jun 13 21:27:06 UTC 2013

On Jun 12, 2013, at 1:18 PM, Portwood, Michael wrote:

> I’m responsible for an interchange site that is currently running 5.5.1 and I’m considering an upgrade to 5.6.3. After visiting the Interchange website, I have two questions:
> 1.       What are the changes/feature changes implemented between the two versions?
> 2.       What challenges will I have performing an in-place upgrade?

Hi Michael,

The 5.5 series was the development branch for the 5.6 release, so things should be relatively compatible between 5.5.1 and 5.6.3; in particular, you should be able to upgrade interchange in-place and have your existing catalogs work with minimal changes.

This of course assumes that you're using a stock version of Interchange 5.5.1; if there have been custom patches made compared to the stock 5.5.1, you'll need to ensure that the code changes between your installed version and stock IC get ported over.

Additionally, as long as you are considering an upgrade, it'd be better to target 5.7.7; despite not being the formal "stable" release on the website, it has had a large amount of development and testing, and will be a nice stepping stone for an upcoming Interchange 5.8.0 release.


David Christensen
End Point Corporation
david at endpoint.com

More information about the interchange-users mailing list