[ic] Problems with Subcatalogs under Interchange 4.9.8

Mike Heins mike at perusion.com
Tue Jul 15 17:56:38 EDT 2003

Quoting Shawn Mathews (eyefivesupport at aol.com):
> I'm taking over maintenance of an interchange 4.9.4 catalog and was looking to upgrade it to 4.9.8.
> My biggest problem is the 4.9.4 implementation used subcatalogs (the client has a different website for each product, and a supersite with all of the products);
> Under 4.9.8 I get the following error message when I try and access a subcatalog:
> [15/July/2003:13:31:58 -0500] hep cattest.eyefiveinc.com/humaneuphoria/index.html Runtime error: do not know how to copy (?-xism:^(\/home\/psmerch\/eyefive_catalogs\/eyefive|\/home\/psmerch\/intr498\/lib\/UI\/pages)) at /home/psmerch/intr498/lib/Vend/Util.pm line 766.
> Any ideas / suggestions?

You would need to post your hep.cfg for anyone to tell. Looks like you
are including a configuration parameter of a regex type, which is an
object that can't be contained in a subcatalog config file.

It is possible that we can go to Data::Dumper cloning to replace the
rather long-in-the-tooth copyref routine used in subcatalog config
merge, but I don't know if that supports regex types either.

Mike Heins
Perusion -- Expert Interchange Consulting    http://www.perusion.com/
phone +1.513.523.7621      <mike at perusion.com>

I don't want to get to the end of my life and find I have just
lived the length of it. I want to have lived the width of it as
well. -- Diane Ackerman

More information about the interchange-users mailing list