[ic] Errors while creating options for products in admin GUI

Kevin Old kold at kold.homelinux.com
Tue Nov 11 21:18:13 EST 2003

On Tue, 2003-11-11 at 15:57, Ryan Grace wrote:
> Hi All,
> I've searched the archives for mention of this problem, but have come up empty.
> I've just moved my functional Interchange site from a development server to a production server.  The process I used to migrate was to install IC on teh new server, do bin/makecat, and then scp the pages/, templates/, html/, and products/ drectories over to the live server form the dev server.  The filesystem paths and d info are the same on the two servers.  The catalog seems to be fully functional when browsing it.
> The problem occurs when trying to add options to an item in the admin GUI.  I go to Items->Item List click hte sku of the item I want to edit and then click OPtions in the top navigation to edit its options.  I choose Simple Options then click the Update button and am presented with an error page that says only Error: at the top and no more detail than that.  I am not getting an error message in my main or catalog error logs, nor in my apache error log.
> Can anyone think of why this might happen?  I was able to add and remove options from items on my dev server just fine.  I'm really stumped here.  Could there be a file permissions problem?
> Thanks in advance for any ideas.

Hi Ryan,

Couple of things to check....

You said you moved pages/, templates/ and products/ over....any reason
you didn't copy everything?

Also, are you using the same user on both dev and prod?

I assume your using the flat-file db, but if not, you did transferred
the db (Mysql, Postgres, ...)?

Also, what verison of IC and what flavor/version of linux?

Hope this helps,

Kevin Old <kold at kold.homelinux.com>

More information about the interchange-users mailing list