[ic] Redhat 9.0 and Perl multithread problems information.

Fredrik Hansen fredrik.hansen at nykoping.nu
Sun Sep 14 12:42:24 EDT 2003

I've just replaced the standard Perl that comes distributed on RedHat9.0 
with the non-multithreaded from stable.tar.gz at perl.com.

This is probably an old issue by now, but I just wanted to share my 
experience since it may help some other having troubles.
In short: 
I have been running a RedHat 9.0 since the day it was released and have of 
course installed a lot of perl modules needed for different things, like 
mimedefang, spamassassin, webmin and so on.
When installing IC on a RedHat 9.0 the setup complains about multithreaded 
perl, which is (after catching up on the subject) a bad decision from 
RedHat to have on the distro.

Anyway, i uninstalled the distributed perl rpm and installed stable.tar.gz from perl.com.
Worked allright, no problems there...but guess what?
All the perl modules was not to be found anymore!
The reason is not too hard to understand, different paths for different 
compilations of perl.
I've simply fetched all the needed modules from CPAN needed again with 
perl -MCPAN -e 'install <modulename>.
IC works like a charm now, no problems whatever reagrding to stability 
Conclusion: When replacing Perl, note which modules that are used before, 
or do the replacing before any modules are installed on a fresh system.

I figure it could be solved by telling the new perl where the modules are 
located, but my knowlegde on perl is limited so don't ask me how to do 
that. :-)

(Sorry for the long mail)

Best Regards,
Fredrik Hansen

More information about the interchange-users mailing list