[ic] GPG error 512....Inappropriate ioctl for device...need help with email encryption

New Media E.M.S. ic_users at newmediaems.com
Mon Feb 9 13:14:49 EST 2004

On Sat, 2004-02-07 at 09:38, Adam Fritz wrote:
> I just recently installed Interchange 5.0.0 and was
> having a bit of trouble getting gpg to run properly. 
> I had a earlier version of IC loaded and GPG
> encryption working correctly on my last server and
> thought i was doing thing exactly the same but
> evidentally i messed up on one part.
> -I have interchance running as user 'adam'
> -I created a keypair on my windows machine and the
> ftp'd them to my server
> -I used  su adam -c 'gpg --import /www/adampubkey.txt'
> and it created a directory called /www/.gnupg with the
> key in it.
> -I ran echo "testing" | gpg --no-default-keyring
> --always-trust
> --keyring /www/.gnupg/pubring.gpg -e -a --batch -t -r
> 'adam at woodloft.com'  and it outputted my keyring with
> now errors.
> -I tried running gpg --list-keys and it looked under
> /root/.gnupg/ but since there is no directory by that
> name it created one...so not sure if this is what
> might be causing the problem or not.
> -I checked all permission on the files and they are
> set to owner adam which is the same name that owns the
> interchange files.
> -I the went to -Administratrion - Preferences and
> added the PGP variable gpg --no-default-keyring
> --always-trust --keyring /www/.gnupg/pubring.gpg -e -a
> --batch -t -r '%s' and the PGP_KEY variable with my
> email address which was set when i created the
> keypair.

That should not be necessary; given what you have done this far, when
you use the Administration tab in the UI to edit Encryption -> PGP_KEY,
you should see a selector which contains a list of available keys 
(which would likely only include the one key you imported earlier).
You just need to ensure that they key you want is select, click 'Ok',
then 'Apply Changes'. Nothing else needs to be set, including the PGP
variable, if there even is one.

If you don't see any keys in the selector for PGP_KEY, you goofed
somewhere: the interchange user ('adam' in your case) does not have the
key you want in it's ring.

- Ed

> -Lastly i went to the catalog.cfg and made sure the
> following lines where there:
> EncryptProgram __PGP__
> EncyptKey __PGP_KEY__
> credit_card    1
> encrypt        1
> encrypt_program    "__PGP__"
> email        '__ORDERS_TO__'
> pgp_cc_key    "__PGP_CC_KEY__"
> pgp_key    "__PGP_KEY__"
> After doing all that i reconfigured the catalog,
> restarted the computer, and started the server.  I
> then went and made a fake order to myself and when i
> hit place order it came up with the error:
> .Inappropriate ioctl for device
> I checked the error log and it stated:
> PGP failed with error level 512, status 2: No such
> file or directory
> PGP hard failure, command that failed: gpg
> --no-default-keyring --always-trust --keyring
> /www/.gnupg/pubring.gpg -e -a --batch -t -r '%s'
> 'adam at woodloft.com'
> Does anyone have any ideas of what might cause this
> problem to go away?  Thank you very much for reading
> this and i hope someone has a solution. 
> __________________________________
> Do you Yahoo!?
> Yahoo! Finance: Get your refund fast by filing online.
> http://taxes.yahoo.com/filing.html
> _______________________________________________
> interchange-users mailing list
> interchange-users at icdevgroup.org
> http://www.icdevgroup.org/mailman/listinfo/interchange-users
New Media E.M.S.              Technology Solutions for Business
11630 Fair Oaks Blvd., #250   eCommerce | Consulting | Hosting
Fair Oaks, CA  95628          edl at newmediaems.com
(916) 961-0446                http://www.newmediaems.com
(866) 519-4680 Toll-Free      (916) 961-0447 Fax

More information about the interchange-users mailing list