[ic] GPG error 512....Inappropriate ioctl for device...need help with email encryption

Adam Fritz thesearcher23 at yahoo.com
Sat Feb 7 12:38:31 EST 2004

I just recently installed Interchange 5.0.0 and was
having a bit of trouble getting gpg to run properly. 
I had a earlier version of IC loaded and GPG
encryption working correctly on my last server and
thought i was doing thing exactly the same but
evidentally i messed up on one part.

-I have interchance running as user 'adam'
-I created a keypair on my windows machine and the
ftp'd them to my server
-I used  su adam -c 'gpg --import /www/adampubkey.txt'
and it created a directory called /www/.gnupg with the
key in it.
-I ran echo "testing" | gpg --no-default-keyring
--keyring /www/.gnupg/pubring.gpg -e -a --batch -t -r
'adam at woodloft.com'  and it outputted my keyring with
now errors.
-I tried running gpg --list-keys and it looked under
/root/.gnupg/ but since there is no directory by that
name it created one...so not sure if this is what
might be causing the problem or not.
-I checked all permission on the files and they are
set to owner adam which is the same name that owns the
interchange files.
-I the went to -Administratrion - Preferences and
added the PGP variable gpg --no-default-keyring
--always-trust --keyring /www/.gnupg/pubring.gpg -e -a
--batch -t -r '%s' and the PGP_KEY variable with my
email address which was set when i created the
-Lastly i went to the catalog.cfg and made sure the
following lines where there:
EncryptProgram __PGP__
EncyptKey __PGP_KEY__
credit_card    1
encrypt        1
encrypt_program    "__PGP__"
email        '__ORDERS_TO__'
pgp_cc_key    "__PGP_CC_KEY__"
pgp_key    "__PGP_KEY__"

After doing all that i reconfigured the catalog,
restarted the computer, and started the server.  I
then went and made a fake order to myself and when i
hit place order it came up with the error:
.Inappropriate ioctl for device

I checked the error log and it stated:
PGP failed with error level 512, status 2: No such
file or directory
PGP hard failure, command that failed: gpg
--no-default-keyring --always-trust --keyring
/www/.gnupg/pubring.gpg -e -a --batch -t -r '%s'
'adam at woodloft.com'

Does anyone have any ideas of what might cause this
problem to go away?  Thank you very much for reading
this and i hope someone has a solution. 

Do you Yahoo!?
Yahoo! Finance: Get your refund fast by filing online.

More information about the interchange-users mailing list