[ic] Question about 'connect failed...(110)" on ic and Mysql server

Mike Heins mike at perusion.com
Thu Jul 15 13:03:28 EDT 2004

Quoting Marty Tennison (marty at sediva.com):
> OS: Debian 3.0
> Kernel: 2.4.20
> Ic: 5.0
> Mysql: 3.23.55
> Perl: 5.6.1 (non threaded)
> ==========================
> Hi Folks,
> I've been trying to track this one down for quite some time now and I'm
> unable to find the answer in the mailing list archives, docs or on the
> web. 
> I'm getting this error in the interchange.cfg error.log file every 30
> minutes or so. 
> "Died in server spawn: table products connect failed -- Can't connect to
> MySQL server on 'mysql.myserver.com' (110)"
> I'm trying to figure out whether I have an IC issue, Mysql issue or DNS
> issue.  I'm getting variations of that error message depending on the
> page requested, but they all have the (110) error code.  A 'grep -R 110'
> from the interchange/lib directory yielded no helpful output.
> Traffic settings:
> PreFork             Yes
> StartServers        5
> MaxRequestsPerChild 100
> HouseKeeping        2
> PIDcheck            120
> MaxServers          0
> As Austin Powers would say - "And, I'm Spent!".  Any help or point in
> the right direction to look would be greatly appreciated. If I have
> forgotten to post any relevant config or error information I apologize
> and will post if requested.

We recently discovered that the latest version of DBD::mysql (2.9003
and 2.9004) have issues with losing connectivity with the server.
This also occurs for us in PreFork mode. The error that shows up, though,
is "MySQL server has gone away".

We downgraded to DBD::mysql 2.1028 and all our problems went away.

Mike Heins
Perusion -- Expert Interchange Consulting    http://www.perusion.com/
phone +1.765.647.1295  tollfree 800-949-1889 <mike at perusion.com>

Friends don't let friends use Outlook. -- Bob Blaylock

More information about the interchange-users mailing list