[ic] CC processing

New Media E.M.S. ic_users at newmediaems.com
Mon May 17 11:05:34 EDT 2004

At 10:26 AM 5/17/2004 -0400, you wrote:

>New Media E.M.S. wrote:
>>At 08:50 AM 5/17/2004 -0400, you wrote:
>>>Hi again all,
>>>First, let me say a HUGE thank you for this lists' existance. It is a 
>>>Next, I'm working on getting CC processing nailed down so I can roll 
>>>this cart out and get it online and taking orders. When I run a test 
>>>order with a live credit card I'm getting this message at the top of the page.
>>> >>>>>>>>>>>>>
>>>  There were errors in your last submission:
>>>     (Payment process): There was an error accepting payment: Real-time 
>>> charge failed. Reason:
>>>  The areas you need to correct are shown in this color below.
>>>problem is...there's nothing colored. the form looks the same as it did 
>>>when I hit the "Place Order" button on the previous screen.
>>>payments settings:
>>>CHECK_ACCEPTED                        0 Payment
>>>COD_ACCEPTED                            0   Payment
>>>CREDIT_CARDS_ACCEPTED           visa mc discover amex   Payment
>>>MV_PAYMENT_ID                           xxxxxxxxx
>>>MV_PAYMENT_MODE                     authorizenet                  Payment
>>>MV_PAYMENT_SECRET                   xxxxxxxxxxxxxxxx          Payment
>>>PO_ACCEPTED                               0     Payment
>>>SETTLE_TRANSACTION                   1
>>>The value for MV_PAYMENT_SECRET is the transaction key that was 
>>>generated by authorize.net that we're currently using on two other 
>>>shopping carts that we're using that we desperately want to get away from.
>>>What am I missing here?
>>>Mark Weaver
>>>American Micro - Webmaster
>>I've seen this happen with threaded Perl - what Perl version are you 
>>running, and did you compile it yourself?
>>- Ed
>Hi Ed,
>Yes, I compiled perl myself and disabled threading. It was the only way I 
>could get Interchange to install.
>Mark Weaver
>American Micro - Webmaster

Ok, I just saw your previous post which included snippets of the error.log. 
It looks like you may be missing this in interchange.cfg:

         Require module Vend::Payment::AuthorizeNet

(restart interchange) ...and you'll need to ensure you have a supplementary 
Perl module or two, see the perldoc for the above-referenced module for 
more info.

- Ed

New Media E.M.S.              Technology Solutions for Business
11630 Fair Oaks Blvd., #250   eCommerce | Consulting | Hosting
Fair Oaks, CA  95628          edl at newmediaems.com
(916) 961-0446                http://www.newmediaems.com
(866) 519-4680 Toll-Free      (916) 961-0447 Fax

More information about the interchange-users mailing list