[ic] Select Failure error?

Kash Monsefi KMonsefi at instinctmag.com
Fri May 28 20:19:35 EDT 2004

Hi all,

First I want to thank everyone who helps out here, you guys are fantastic.
Now on to the problem:

I need to preface this by saying that my Interchange ver 4.8 has been
running smoothly for years without a problem.  As such, I have not changed
anything at all over that time.  However, beginning a few months ago, some
customers said that when they went to checkout, they would get an error
message, so they would have to try again.  Then they would notice that their
credit cards were charged twice.  This problem has actually been getting
worse over time, with more and more customers having the same problem, and
now it's happening several times a day, with some of them getting errors
(and charges) several times before it finally goes through.  I was able to
recreate the problem (finally) and here's what I have tried/found out:

- The error message is 
(signio): Charge failed, reason: Charge error: -13 Reason: Select failure.
Please call in your order or try again.
- I *do not* get a copy of the order sent to me via email when such an error
- My processor is Verisign (I know they suck and am actively working on
getting a new processor).  On my account manager, I can see that the charge
happens without any errors, the charge goes through normally with no error
- I've tried updating to the latest Signio.pm, but the errors still keep
- I've tried updating to the latest PFProAPI.pm, but the errors still keep
- I've tried using the alternate charge program, pfpro instead of
PFProAPI.pm, but the errors keep happening.

As much as I'd like to blame Verisign, it seems the problem is not likely
coming from their end.

Anyone have any ideas what this could be about?

Kash Monsefi

More information about the interchange-users mailing list