[ic] ensim & interchange

Gary Norton gnorton at broadgap.com
Tue Jan 11 12:25:17 EST 2005

>I have installed interchange on an Ensim Pro for RHEL box and have 
>not been able to get it to work.
>When tried from the browser it either time outs or give an error 
>stating the the interchange daemon is busy or not available.
>Interchange was installed from root access.
>Almost there but not there yet :(
>Any pointers to how to set the ownership or permissions to get the 
>link program to access Interchange?
>Thanks in advance,

I have IC installed in /usr/local/interchange owned by root and the 
catalogs installed in /home/virtual/#SITE_NAME#/catalogs/#IC_CAT#.

The site admin should own files within the site, but the interchange 
user is added to the site admins group.

I could only get it to work with TLINK however. After a makecat change 
the owner of /home/virtual/#SITE_NAME#/var/www/cgi-bin/#LINK_PROG# to 
the site admin and set ownership to 755.

Copy /var/www/html/interchange-5/* to 
/home/virtual/#SITE_NAME#/var/www/html/interchange-5 and make the site 
admin owner. If you don't do this step your admin interface will not 
display properly.

This has worked for me on with version of IC from 4.8-5.3 and with Ensim 

Good luck,

More information about the interchange-users mailing list