[ic] Protx Payment Gateway

Curtis, Michael [CCC-OT_IT] michael.curtis at citigroup.com
Thu Dec 21 05:13:18 EST 2006

Rather a lot to enquire about but as all seem to relate to Protx Payment Gateway issues then please bear with me

Original configuration
FreeBSD 6.0
Perl 5.8.8 Unthreaded
IC 5.4.1
Mysql 5.x

Configuration now
Fedora Core 6
Perl 5.8.8 Threaded
IC 5.4.1
Mysql 5.x

Standard Store was created and locale changed to UK with shipping configured to use Royal mail so test orders (From P.O's) could be created....they were all o.k.

Installed Protx 1.0.9f according to the doc's and now I have a few problems

1 using transactions.txt & transactions.mysql from the protx upgrade & then removing .transactions.sql
The table fails to build and the catalog fails to start, reinstating the original transactions.txt & transactions.mysql then the table will build and the catalog starts

2 Adding the columns with mysql admin using transactions.mysql to identify the additional columns allows the catalog to start but the 'key' column 'code' is now empty i.e. I did have entries such as 'TEST001' now there is no data in the table.column 'transactions.code' on a fresh order, transactions.code is not updated (There must be somewhere in UI to set the numbering system but I cannot find it!)

3 On trying to use a Credit Card transaction I get 
x.x.0.50 rqAKSV6h:x.x.0.50 - [16/December/2006:19:35:42 +0000] standard4 /cgi-bin/standard4/process Non-existent order routing main, skipping.
x.x.0.50 rqAKSV6h:x.x.0.50 - [16/December/2006:19:35:43 +0000] standard4 /cgi-bin/standard4/process Unknown charge type: protx
x.x.0.50 rqAKSV6h:x.x.0.50 - [16/December/2006:19:35:43 +0000] standard4 /cgi-bin/standard4/process Safe: Real-time charge failed. Reason: 
> 		die errmsg(
> 				"Real-time charge failed. Reason: %s\n",
> 				errmsg($Session->{cybercash_error}),
> 			);
x.x.0.50 rqAKSV6h:x.x.0.50 - [16/December/2006:19:35:43 +0000] standard4 /cgi-bin/standard4/process Route log failed.
x.x.0.50 rqAKSV6h:x.x.0.50 - [16/December/2006:19:35:43 +0000] standard4 /cgi-bin/standard4/process ERRORS on ORDER :
> Error during creation of order routing log:
		> Route log failed. at /usr/local/interchange/lib/Vend/Order.pm line 1835.

Your help in solving these issues will be most welcome



More information about the interchange-users mailing list