[ic] Form Value Submit Problem

Postfix User postfixjob at gmail.com
Thu Sep 7 08:46:48 EDT 2006


Using Interchange 5.4.0 on CentOS.

I have a weird form submit problem that I cant track down... Maybe
someone can help.

I have written a custom user tag to calculate shipping for a specific
saved cart at checkout, allowing a user to select different shipping
methods for different carts.

<FORM ACTION="[process secure=1]" METHOD="POST">
<input type=hidden NAME=mv_doit       value=refresh>
<input type=hidden NAME=mv_nextpage   value="ord/checkout">
<input type=hidden name=mv_check      value="Save_database">
<INPUT TYPE=hidden NAME="mv_order_profile" VALUE="credit_card">

[loop list="abc xyz"]
  Select Shipping Method:
  <SELECT NAME="[loop-code]_ship" onChange="checkout.submit()" SIZE="1">
    [ship_order_cost cart="[loop-code]"]

The [ship_order_cost] global UserTag that I have written is functional
as it correctly generates the shipping cost for each cart and
populates the select menu with the proper data.

The problem that I am having is that when this generates the actual
HTML, it allows me to submit both of the select menus, however, only
the first select menu (abc_ship) saves.  The second menu (xyz_ship)
does not save or update its value in the users session.

Accordingly, I did a [dump values] to see if there is even an entry
for xyz_ship saved to the session and there is not.

Does anyone have any pointers to assist with why it is saving one but
not the others information?


More information about the interchange-users mailing list