[ic] IC 5.6.0 fresh install : catalog loose MysQL...

Davor Ocelic docelic at spinlocksolutions.com
Sun Oct 19 14:06:04 UTC 2008

> I can't understand why mysql is not activated and i fall back to DBM. :(
> A perl script with DBI & DBD::MySQL is working, so perl seems to be working.
> MySQL is up and running, interchange mysql user is working (i've tried)
> I've tried to put back my all interchange directory and launch 
> interchange, same thing.
> Then i've create a new catalog (mysql_test) and for this one, mysql is 
> ok with interchange !
> Did someone have already see this behavior ?

Did you copy over your products/ directory as-is?

Some tables are always kept in GDBM, including variable.txt where
MySQL connection settings are defined.

If you have copied *.gdbm files over to the new server and the
system architecture does not match, IC will see dbm files there and
try to open them, but will not succeed (due to binary format

So what you should do is delete all *dbm files in products/ to 
cause their regeneration; and then see if it works.

rm products/*dbm
interchange -r


More information about the interchange-users mailing list