[ic] ActionMap breaks subcatalog

David Christensen david at endpoint.com
Thu Jan 8 00:26:26 UTC 2009


> When defining an ActionMap for a subcatalog, an error is produced when
> trying to load a page.  ActionMap does not appear to break the parent
> catalog, only the subs.
> This ActionMap is defined in both the parent and sub catalogs....
> ActionMap foo sub { return 1; }
> When the interchange server is started, all is well.  Trying to  
> access a
> page on the sub catalog produces this error.
> store1 /cgi-bin/store1/ Runtime error: do not know how to copy
> Safe=HASH(0xad7aa98) at /usr/local/interchange/lib/Vend/Util.pm line  
> 818.
> I was also able to produce a slight different error, but not sure  
> how...
> store1 /cgi-bin/store1/ Runtime error: do not know how to copy
> Safe=CODE(0xaf8f6c0) at /usr/local/interchange/lib/Vend/Util.pm line  
> 818.
> I have done some testing and "swapped" catalogs (made the parent the
> sub), the error remained.  So I think it *may* be a bug.

Do you have some more specific information such as your Interchange  
version number, the specific name of the ActionMap, and the names of  
the parent and subcatalogs?  Are these errors occurring on every page  
in the sub-catalog or only on certain pages?  Are there any other  
interesting messages in interchange and the catalogs' error/debug  
logs?  Any messages when restarting interchange?


David Christensen
End Point Corporation
david at endpoint.com

More information about the interchange-users mailing list